smarty compat

1.0 1.1 1.2 1.3

Smarty compatibility layer for block plugins, this is used internally and you should not call it.